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C H A P T E R  1
Introduction

• Who Should Use this Guide?, page 1

• Server Installation Documents, page 2

• Platform Model Options, page 2

Who Should Use this Guide?
This guide is intended to be used by Cisco partners who are planning to install a Cisco Business Edition 6000
H/M Unified Communications appliance. This guide contains the tasks that you must complete to install the
software.

The following table outlines each of the ordering and deployment options that are available. Choose the option
that matches your requirements.

Table 1: Installation Guide Usage for each Deployment Option

Use this guide?Deployment Option

If you ordered your server via the Config To Order Portal (CTOP), your
server arrives with core UC applications pre-installed.

Use this guide to install and configure additional UC applications, if
required.

Config To Order

Use this guide to customize your installation.Customized

The Pre-configured option is not available for BE Series version 11.5 and later.Note
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Server Installation Documents
The following diagram illustrates the documents that are available for Cisco Business Edition 6000 installation
and how each fits into the setup process when in the setup process.

The following documents are available:

• Quick Start Guide—Use this guide to unpack the server and install it in a rack.

• Installation Guide for Cisco Business Edition 6000—Use this guide to install application software on
the Business Edition server.

• UC Applications Installation and Configuration Documents— Click on the BE 6000 Version here, and
then click on the Component Documentation tab to access the relevant documents to install or configure
other UC applications.

Platform Model Options
Cisco BE6000 platforms are built on virtualized Cisco Unified Computing System

™
(Cisco UCS

®
) products,

which are designed for performance and density over a wide range of company sizes and business workloads.
There are three models:

• BE6000H: Supports nine collaboration application options in a single virtualized server platform;
maximum capacity of 1000 users, 2500 devices, and 100 contact center agents. Ideal for medium-scale
end-to-end collaboration deployments

• BE6000M: Supports five collaboration application options in a single virtualized server platform;
maximum capacity of 1000 users, 1200 devices, and 100 contact center agents. Ideal for medium-scale
end-to-end collaboration deployments.
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• BE6000S: Supports five fixed collaboration applications on an integrated router/gateway/virtualized
blade server platform; maximum capacity of 150 users and 300 devices. Ideal for small-scale "office in
a box" collaboration deployments

Figure 1: Cisco Business Edition 6000 and 7000 Series
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C H A P T E R  2
Pre-installation

• Before You Begin, page 5

• Pre-installation Task Flow, page 5

Before You Begin
Your Cisco Business Edition 6000 server should already be rack-mounted and connected to power and data
networks. For instructions, refer to the Quick Start Guide for Cisco Business Edition that was packaged with
your server. You can also download a copy at:

http://www.cisco.com/c/en/us/support/unified-communications/business-edition-6000/
products-installation-guides-list.html

Pre-installation Task Flow
Review the following topics before you begin your installation.

Procedure

PurposeCommand or Action

Plan which UC applications you want to install.Plan your UC Applications, on page
6

Step 1

Collect the required network details for your
installation. You will need information such as IP

Collect RequiredNetwork Information,
on page 7

Step 2

addresses and DNS information when you install the
software.
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Plan your UC Applications
Before you begin any installation, plan which UC applications you are going to install.

If you are using the Config to Order Portal(CTOP) to order your server, you must plan and specify the
UC applications before submitting the CTOP configuration.

Note

For information on the UC applications that are available for installation, and on how to design your Business
Edition collaboration deployment refer to the following sites:

• Cisco Business Edition 6000 and Cisco Business Edition 7000 Co-residency Policy Requirements—This
document contains information on the Cisco virtualized applications that are available for installation
on a Cisco Business Edition 6000 system and the conditions that you must meet to run those applications
and any third-party applications on a Business Edition server.

http://www.cisco.com/c/en/us/support/unified-communications/business-edition-6000/
products-device-support-tables-list.html

• Unified Communications in a Virtualized Environment—This wiki site contains information on Cisco's
catalog of UC applications and provides information on how to design your deployment.

http://www.cisco.com/go/uc-virtualized

• Preferred Architecture Guides for Midmarket—Preferred Architecture documents and CVD guides
offer prescriptive, end-to-end system solutions for Collaboration and Voice deployment. The design
overviews provide a basic understanding of the products and their roles in the Preferred Architectures,
including high-level best practices. The CVD guides provide more detailed design and deployment
recommendations that help streamline the implementation of Preferred Architectures

http://www.cisco.com/c/en/us/solutions/enterprise/design-zone-collaboration/index.html

• Midmarket Collaboration CVD Guides—Midmarket CVDs provide detailed design and step-by-step
deployment information for collaboration solutions built on the Cisco Business Edition 6000. These
CVDs are based on the core recommendations of the Preferred Architectures, and in some cases, they
offer additional solution designs as extensions or alternatives to the Preferred Architectures.

http://www.cisco.com/c/en/us/solutions/enterprise/design-zone-collaboration/index.html

Pre-deployed Applications
If you did not configure your server using the CTOP service, you will find the following applications
pre-deployed on the server, ready for you to complete installation as required.

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Prime Collaboration Provisioning

• Cisco Paging Server
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You can follow the procedures in this guide to install additional applications.

Collect Required Network Information
Before you begin the installation, collect the following network information for your solution.

Table 2: Network Settings to Collect for New Installations

Collect the following information:Deployment

Network settings are already configured for CTOP prepared servers. Proceed to
the next step.

Config To Order

Collect the following network settings for your installation:

• Subnet mask

• Gateway IP Address

• VMware Hypervisor ESXi IP address

• Cisco Integrated Management Controller (CIMC) IP address

• UC application IP addresses

• DNS server IP address

• UC application hostnames

• (Optional) Domain name

• NTP server IP address

• Time zone

• (Optional) SMTP server

For a validated network design, see theUnified Communications Using
Cisco BE6000CiscoValidatedDesign (CVD) at http://www.cisco.com/
c/en/us/solutions/enterprise/design-zone-collaboration/index.html.

Note

Customized
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C H A P T E R  3
Installation

• Installation Overview, page 9

• Installation Task Flow, page 10

Installation Overview
This chapter describes the tasks that you must perform to install software on your Business Edition 6000
server. It contains two main task flows that describe how to install software on the server.

For Customized deployments, use the tasks in this chapter to configure VMware and install application software
on your server.

If your server was ordered via the Config To Order Portal, your server is already installed with VMware and
UC applications. Complete only those tasks that are required to install your additional UC applications.

Preloaded File Types in the Datastore
In addition to pre-deployed virtual machines, Cisco Business Edition servers are shipped with selected
Collaboration application software that is pre-loaded on the datastore. Following is a breakdown of the file
types for application installs:

• ISO Files—An ISO file is a DVD image containing application install files (for example,
Bootable_UCSInstall_UCOS_11.0.1.20000-2.sgn.iso). An ISO file is present for a UC
application only if the OVA file for that application does not include the application software.

• OVA Files—Each UC application has an associated Open Virtualization Archive (OVA) file, which is
used to package and deploy the virtual machine. There are two types of OVAs for Business Edition
servers:

◦Some OVAs are templates that define the VM, but do not include any application software. For
those applications, there is an associated ISO file in the datastore (for example,
cucm_11.5_vmv8_v1.0.ova and associated ISO file
Bootable_UCSInstall_UCOS_11.0.5.10000-6.sgn.iso ). For the installation, you
must deploy the OVA template and install the software using the associated ISO file.
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◦Other OVA files define the VM and include the application software (for example,
cpc-provisioning-11.2.0-523-small.ova ). For these applications, there is no ISO
file. You can deploy the VM and install the software using the OVA file.

For information on which ISO and OVA files are pre-loaded in your server's datastore, refer to the preload
summary for your server at http://www.cisco.com/c/en/us/support/unified-communications/
business-edition-6000/products-release-notes-list.html.

Cisco recommends that you archive the OVA-ISO directory locally. If a server fails, the replacement
product will not include pre-loaded content.

Note

Installation Task Flow
Perform the following tasks to install software on your Cisco Business Edition 6000 server.

Procedure

PurposeCommand or Action

Configure CIMC for your Business Edition 6000 server.Configure Cisco Integrated
Management Controller, on page
11

Step 1

Configure the ESXi Virtualization Hypervisor host on the
Business Edition 6000 server.

Configure VMware vSphere
Hypervisor, on page 13

Step 2

Delete any pre-deployed VMs that you do not require.Delete VMs, on page 20Step 3

For servers ordered via the Config To Order
Portal, you can skip this step.

Note

Deploy virtual machine OVAs for each UC application
that you want to install.

Deploy Virtual Machine OVAs, on
page 21

Step 4

If your Business Edition 6000 deployment includes Cisco
Unity Connection, customize the Unity Connection VM.

Customize VM for Cisco Unity
Connection, on page 22

Step 5

For UC application installations that require an ISO file,
mount the ISO file on the application VM.

Associate Application ISO Files to
VM, on page 23

Step 6

For a list of applications that use ISO installation
files, see the Preload Summary for your server.

Note

Optional. Use touchless installation to install any of the
following core UC applications:

Install UC Applications Using
Touchless Installation, on page 24

Step 7

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Unified Contact Center Express
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PurposeCommand or Action

If you prefer, you can use manual installation for
these applications.

Note

Use the manual interactive process to install any remaining
UC applications.

Install UC Applications Manually,
on page 28

Step 8

Configure Cisco Integrated Management Controller
Cisco Integrated Management Controller (CIMC) is the management interface for the Cisco UCS Server.
CIMC runs within the server, allowing remote administration, configuration, and monitoring of the server via
web or SSH command line access.

Complete the following tasks to configure CIMC on a Business Edition 6000 server for customized and
pre-configured deployments.

If you ordered your server via the Config To Order Portal, CIMC is already set up on your server. Skip
to Configure VMware vSphere Hypervisor, on page 13.

Note

Procedure

PurposeCommand or Action

Power on the server and configure basic CIMC
IP addressing details.

Power On and Initial CIMC Setup, on page
11

Step 1

Configure DNS and NTP settings for the CIMC
interface.

Complete the CIMCConfiguration, on page
13

Step 2

Power On and Initial CIMC Setup
Use this procedure to power on the server and begin basic Cisco Integrated Management controller (CIMC)
configuration.

Before You Begin

Ensure that the BE6000 server has been rack-mounted, connected to a power supply, connected to the data
network, and that a monitor and keyboard are connected to the server, as described in the Quick Start Guide.
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Procedure

Step 1 Verify that power is connected and that the power button LED is orange.
Step 2 Push the server power button and verify that it changes to green
Step 3 Watch the boot process on the monitor.
Step 4 When the blue Cisco logo appears, press F8 to enter the CIMC configuration dialog.

Figure 2: Press F8 at the CIMC Boot Screen

Step 5 When prompted, enter the username admin and create a new password.
Step 6 On the CIMC configuration screen, complete the following details:

• CIMC IP address

• Subnet mask

• Gateway IP address

Figure 3: Enter the CIMC IP Address Details

Step 7 When complete, press F10 to save your changes and boot the system.

What to Do Next

Complete the CIMC Configuration, on page 13

   Installation Guide for Cisco Business Edition 6000 H/M, Release 11.5
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Complete the CIMC Configuration
Use this procedure to configure DNS and NTP settings in the CIMC interface.

Procedure

Step 1 In a web browser, enter the CIMC IP address and log in with the username admin and the password that you
created in the previous task.

Step 2 From the left hand menu, select the Admin tab, and click Network.
Step 3 In the main screen, select the Network Settings tab.
Step 4 From Common Properties, change the Hostname setting to the CIMC hostname.
Step 5 From IPv4 Properties, change Preferred DNS Server to the IP address that you have specified for the DNS

server.
Step 6 In the main screen, select the NTP Settings tab.
Step 7 Check the Enable NTP check box.
Step 8 In the Server 1 field, enter the NTP server IP address.
Step 9 Select Save Changes from the bottom right hand corner of the page.

Configure VMware vSphere Hypervisor
Complete the following tasks to set up the VMware vSphere Hypervisor.

Procedure

PurposeCommand or Action

Customize your VMware vSphere Hypervisor to
allow remote access using vSphere client.

Customize VMware vSphere Hypervisor
Remote Access, on page 13

Step 1

Configure your VMware vSphere Hypervisor with
NTP settings and fault tolerance.

Access and Configure VMware vSphere
Hypervisor, on page 18

Step 2

Customize VMware vSphere Hypervisor Remote Access
Follow this procedure to customize the Virtualization Hypervisor (VMware vSphere Hypervisor) to enable
remote access from your PC using the vSphere client.

For servers ordered via the Config To Order Portal, skip to Step step 5.Note
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Procedure

Step 1 When the hypervisor boots, the ESXi Direct Console User Interface displays on the monitor as shown in the
following figure

Figure 4: Console Screen After ESXi Loads

Step 2 Press F2 to enter the System Customization menu as shown in the following figure.

   Installation Guide for Cisco Business Edition 6000 H/M, Release 11.5
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The default username is root and password is password.

Figure 5: ESXi System Customization Menu

Step 3 Choose Configure Password to change the password.
If your applications are pre-deployed, skip to Step step 5.
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Step 4 To assign a static IP address, select the Configure Management Networkmenu, and follow the instructions
on screen to change “IP Configuration” as shown in the figure below.

Figure 6: Assign Static IP Address to ESXi Host
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16

Installation
Configure VMware vSphere Hypervisor



Step 5 Connect your PC to the data network, and browse to the new hypervisor IP address. Verify the web page as
shown in the figure below.

Figure 7: Hypervisor Welcome Page

Step 6 If not already installed on your PC, download and install the vSphere client.
The vSphere client can be downloaded from the internet, or accessed in the datastore.
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What to Do Next

Access and Configure VMware vSphere Hypervisor, on page 18

Access and Configure VMware vSphere Hypervisor
Some Business Edition applications require the host to have a valid time reference. Follow these steps to
access the ESXi host to configure NTP as well as configure fault tolerance for network interface cards (NICs)
using the NIC teaming feature, view preinstalled applications, and browse the datastore to verify the preloaded
collaboration application software.

Procedure

Step 1 Launch the vSphere client application and type the IP address of the VMware vSphere Hypervisor.

Figure 8: Access VMware vSphere Hypervisor Using vSphere Client

Step 2 Use the login credentials that you previously configured.
Step 3 (Optional) The Cisco UC Virtualization Hypervisor Plus license is pre-installed and is therefore ready for use

on delivery. If you need to reapply or upgrade the license, follow these steps:
a) If you have ordered a license upgrade, refer to the documentation provided with your order to obtain the

license key. If using the virtualization hypervisor license, this is the Master Serial Number that is shipped
with the server.

The Master Serial Number is pre-activated. You do not need to register it. The serial number is
hardcoded for a two-CPU system. You cannot combine, change, or register it with other licenses.

Note

b) Navigate to Configuration > Software > Licensed Features, and click Edit.
c) Select Assign a new license key to this host.
d) Click Enter Key....
e) Type in the Master serial number.
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f) Click OK to close configuration dialogs and apply the license.

Step 4 Configure NTP settings:
a) Navigate to Configuration > Software > Time Configuration.
b) Click Properties to launch the Time Configuration screen.
c) Update the Time.
d) Click Options... .
e) Select NTP Settings.
f) Click Add and type the IP address of NTP server. Repeat this step to add multiple NTP servers.
g) Click OK.
h) Select General > Start and Stop with Host.
i) Click Start button. Click OK to close the configuration screens.

Step 5 Optional. Configure fault tolerance by using the NIC teaming feature in VMware:
a) Navigate to Configuration > Hardware > Networking.
b) Click Properties for “Standard Switch: vSwitch0,” as shown in the figure below.
c) In the configuration screen vSwitch0 Properties, select the tab Network Adapters.
d) Click Add… to add the NIC that is connected to data network.
e) Follow the interactive configuration dialogs and close the configuration screens until you see two or more

NICs are added to vSwitch0, as shown in the figure below.
By default, only one NIC is enabled for the hypervisor and identified as vmnic0.Note

If connecting teamed NICs to a Cisco switch channel-group, ensure that the NIC teaming load
balancing policy is set toRoute based on IP hash. For more information about this policy and other
aspects of hypervisor networking for Cisco Collaboration applications, see the Appendix, Configure
NIC Teaming for Business Edition 6000, on page 37.

Note

Step 6 Browse the datastore:
a) Navigate to Configuration > Hardware > Storage.
b) Click Datastore to list the datastores in the Business Edition server.
c) Select datastore1, then right-click and selectBrowse Datastore as shown in the following figure. Preloaded

software is stored in the /OVA-ISO directory.

Figure 9: Browse Datastore to View Preloaded Collaboration Virtual Machines and Preloaded Software
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Step 7 (Optional) Cisco recommends that you archive the OVA-ISO directory locally. If a server fails, the replacement
product does not include preloaded content.

What to Do Next

Delete VMs, on page 20

Delete VMs
If you want to use a different application version to those that have been pre-deployed, delete these virtual
machines from the vSphere inventory and install the preferred version.

Procedure

Step 1 Log in to vSphere Client.
Step 2 Locate the virtual machine that you wish to delete.

Figure 10: Delete Any VMs that you are not Using

Step 3 If the VM has a green triangle, right-click the icon and select Power > Power Off.
The green arrow disappears as the VM powers off.

Step 4 Right-click the VM and select Delete From Disk.
Step 5 Repeat this procedure for each virtual machine that you wish to remove.

What to Do Next

See the next section to deploy Virtual Machines.
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Deploy Virtual Machine OVAs
For each application that you want to install, deploy the appropriate virtual machine OVA file.

For Customized deployments, you must either use the default pre-deployed VMs, or deploy new instances if
you are installing an older version. If you do not need to deploy any new VMs, you can skip forward to the
next section.

For Config To Order deployments, you need only deploy VMs for the additional applications that you want
to install.

The OVA template file defines the virtual machine for specific applications. OVA templates are deployed
in seconds, while a packaged OVA may take longer to deploy.

Note

Figure 11: Deployed Application VMs Viewed in VSphere Client

Procedure

Step 1 On the vSphere Client, navigate to File > Deploy OVF Template.
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The Deploy OVF Template screen is launched.

Step 2 Browse and select the source OVA template file on your PC. For application and filename mapping, see the
Build Summary PDF in the datastore OVA-ISO directory, or download from here: http://www.cisco.com/c/
en/us/support/unified-communications/business-edition-6000/products-release-notes-list.html.

Step 3 If prompted to accept license agreements, continue to click Next.
Step 4 Specify a meaningful name for the virtual machine.
Step 5 Select the appropriate virtual machine size for your deployment, if prompted.
Step 6 Set the remaining parameters, as required.
Step 7 If prompted for the Disk Format, specify Thick Provision Lazy Zero.
Step 8 Deploy VMs for all of your UC applications before proceeding to the next task.

What to Do Next

If your system includes Cisco Unity Connection, Customize VM for Cisco Unity Connection, on page 22

Otherwise, Associate Application ISO Files to VM, on page 23

Customize VM for Cisco Unity Connection
For Customized installations, use this procedure to configure your Cisco Unity Connection virtual machine
settings to ensure optimum performance.

Pre-configure

Procedure

Step 1 From the virtual machine inventory in the vSphere client, right click the Unity Connection entry and select
Edit Settings.

Step 2 Click the Options tab.
Step 3 If installing a version earlier than 11.5, select the Advanced > General menu, and click Configuration

Parameters. Click Add Row and complete the following details:
a) Enter sched.cpu.latencySensitivity in the Name column.
b) Enter High in the Value column.

Step 4 If you want to use Unity Connection, or Unified or Integrated Messaging, do the following:
a) Select the Hardware tab.
b) Select the CPUs menu and set the number of virtual sockets to 2.
c) Select the Resources tab.
d) Select the CPU menu and increase the Reservation to 3598MHz.

What to Do Next

Associate Application ISO Files to VM, on page 23
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Associate Application ISO Files to VM
If you have deployed a newVM template for any of the following applications, use this procedure to associate
the ISO installation files that will be used to complete the installation. Otherwise, you can proceed to the
installation tasks.

This step is not required for default pre-deployed VMs.Note

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Unified Contact Center Express

• Cisco Emergency Responder

For an up to date list of installation files for your server, see the Preload Summary for your server in the
datastore OVA-ISO directory or at: http://www.cisco.com/c/en/us/support/unified-communications/
business-edition-6000/products-release-notes-list.html

Note

Procedure

Step 1 In the vSphere client, select the UC application virtual machine.
Step 2 Select Inventory > Virtual Machine > Edit Settings.
Step 3 From the Hardware tab, select CD/DVD Drive.
Step 4 Select Datastore ISO File.
Step 5 Browse to the datastore and locate the application ISO file.
Step 6 Select the file and click OK.
Step 7 Under Device Status, enable the Connected and Connect at power on option.
Step 8 Repeat this procedure for each application that you want to install that includes an ISO file.

What to Do Next

Install your UC applications using either of the following procedures:

• Install UC Applications Using Touchless Installation, on page 24

• Install UC Applications Manually, on page 28
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Install UC Applications Using Touchless Installation
Touchless installation allows you to install multiple UC applications simultaneously, across hosts if required,
without having to interact with the system while the install process runs. While you must prepare the system,
touchless installation can save time, particularly if you want to install multiple applications. If you are installing
only one or two applications, you may prefer to follow the manual procedure in the following section.

Use touchless installation to install the following applications:

• Cisco Unified Communications Manager

• IM and Presence Service

• Cisco Unity Connection

• Cisco Unified Contact Center Express

• Cisco Prime Collaboration Deployment - Follow step 2 onwards for installation.

Procedure

PurposeCommand or Action

Generate answer files (AFG files) for UC
applications.

Generate Answer Files, on page 24Step 1

Use your AFG files to create virtual floppy images.Create Virtual Floppy Images, on page
25

Step 2

Upload your virtual floppy images to the datastore.Upload Virtual Floppy Images to
Datastore, on page 26

Step 3

Mount each virtual floppy on the corresponding
UC application VM.

Mount Virtual Floppy onVM and Set Boot
Option, on page 27

Step 4

Run the touchless installation of your UC
applications. We recommend that you run your
installations simultaneously.

Run Touchless Installation, on page 27Step 5

Generate Answer Files
Use this procedure to generate answer files for the touchless installation of your UC applications.

We recommend that you create application-specific folders (for example, UCM, IMP, CUC, CCX) in
which to save the generated files so that you do not get the files mixed up.

Tip
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Procedure

Step 1 Go to the online answer file generator at: www.cisco.com/web/cuc_afg/.
Step 2 From the Product drop-down menu, select the UC application for which you want to generate answer files.
Step 3 Select the Version that you want to install.
Step 4 Complete the remaining fields with the installation details that you want to configure on the server. For

example, you can assign items such as passwords, IP addressing, and DNS settings.
Step 5 Click Generate Answer Files to generate the platformConfig.xml file for that UC application.

Each UC application generates a platformConfig.xml file. Cisco Unified Communications Manager
also generates a clusterConfig.xml file.

Step 6 Save the generated answer files as follows:

• For Cisco Unified Communications Manager, save both the platformConfig.xml and
clusterConfig.xml files in the UCM folder.

• For other UC applications, save the platformConfig.xml file in the relevant application folder.

Step 7 Repeat these steps for each UC application for which you want to use touchless installation.

What to Do Next

Create Virtual Floppy Images, on page 25

Create Virtual Floppy Images
Use this procedure to create virtual floppy images from the answer files. You will use the virtual floppy images
in your touchless installation.

We recommend that you follow the recommended naming conventions for your .flp files.Tip

Before You Begin

You can use Winimage to create the virtual floppy images. You can download Winimage from http://
www.winimage.com/download.htm. You can also use other tools, such as BFI, to create virtual floppy images.
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Procedure

Step 1 In Winimage, select File > New.
Step 2 From the Standard format, select 1.44 MB and click OK.
Step 3 Drag the platformConfig.xml file for the UC application onto the Winimage window.
Step 4 When prompted to inject the file into Winimage, click Yes.
Step 5 Cisco Unified Communications Manager only. Drag the clusterConfig.xml file onto the Winimage

window.
Step 6 Select File > Save As.
Step 7 Save the file as a virtual floppy image (.flp file) using the following naming conventions:

• Cisco Unified Communications Manager—ucm.flp

• IM and Presence Service—imp.flp

• Cisco Unity Connection—cuc.flp

• Cisco Unified Contact Center Express—ccx.flp

Step 8 Repeat this procedure for each UC application for which you want to use touchless installation.

What to Do Next

Upload Virtual Floppy Images to Datastore, on page 26

Upload Virtual Floppy Images to Datastore
Use this procedure to upload the virtual floppy images to the datastore.

Procedure

Step 1 Start the vSphere client.
Step 2 Select the Configuration tab.
Step 3 Select Storage.
Step 4 Right-click on a datastore and Browse the datastore.
Step 5 Navigate to the destination directory and click the Upload files to this datastore icon.
Step 6 Upload the vFloppy images to the AFG folder.
Step 7 At the Upload/Download warning, click Yes.
Step 8 Close the Datastore Browser window.

What to Do Next

Mount Virtual Floppy on VM and Set Boot Option, on page 27
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Mount Virtual Floppy on VM and Set Boot Option
Use this procedure to mount the UC application virtual floppy images on their corresponding VM.

This step is not required for pre-deployed VMs as they are already configured.

Procedure

Step 1 In the vSphere client, select the UC application virtual machine.
Step 2 Select Inventory > Virtual Machine > Edit Settings.
Step 3 From the Hardware tab, select Floppy drive.
Step 4 Select Use existing floppy image in datastore.
Step 5 Browse to the datastore and locate the virtual floppy image.
Step 6 Select the file and click OK.
Step 7 Under Device Status, enable the Connected and Connect at power on option.
Step 8 Click the Options tab. Under Boot Options, check Force entry to BIOS, and then click OK.
Step 9 Repeat this procedure for each UC application for which you want to perform touchless installation.

What to Do Next

Run Touchless Installation, on page 27

Run Touchless Installation
After you have mounted your virtual floppy drives to your application VMs, run the touchless installation
process. It's recommended that you run all of your touchless installations simultaneously.

If your VM is pre-deployed, you need to perform step 6 only.Note

Procedure

Step 1 In vSphere client, right-click the VM and select Open Console.
A console window opens.

Step 2 Click the Power On icon in the console tool bar to power on the virtual machine.
Step 3 When the BIOS screen appears, configure the following boot order:

a) CD-Rom
b) Hard Drive
c) Removable Devices
d) Network

Step 4 Save the settings and exit the console.
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The UC application installation commences immediately.
Step 5 Repeat these steps for each UC application that you want to install.
Step 6 Once the installations are complete, remove the vFloppy configurations from the virtual machines.

What to Do Next

Use the manual method to install any remaining UC applications in the next section.

Install UC Applications Manually
Use this procedure to follow the interactive install process to install any UC applications that do not have a
touchless install option such as Cisco Emergency Responder.

For details specific to Cisco Prime Collaboration Provisioning or Cisco TelePresence Video
Communications Server installations, refer to:

Note

• Complete Other Applications Installation , on page 29

• Complete Cisco Expressway Installation, on page 29

If you want to use this method to install both Cisco Unified CommunicationsManager and IM and Presence
Service, you must complete the installation of the Unified Communications Manager publisher first.

Note

Procedure

Step 1 In vSphere Client, power on the VM for the application that you want to install.
Step 2 Right-click the VM, and choose Open Console.

A console window appears.
Step 3 Follow the screen prompts to install the application from the console.
Step 4 If you are using the manual method to install both Cisco Unified Communications Manager and IM and

Presence Service, once the Cisco Unified Communications Manager publisher node installation completes,
do the following:
a) From the vSphere console, log in to the Cisco Unified Communications Manager CLI.
b) Run the set network cluster subscriber dynamic-cluster-configuration 24 command.
c) Open a vSphere console window for the IM and Presence or subscriber virtual machine.
d) Power On the virtual machine.
e) Enter the configuration information for the application to complete the installation.

Step 5 Repeat this procedure for each UC application that you want to install.
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Complete Packed Virtual Machine (OVA) Installation

Complete Other Applications Installation
Use this procedure to complete installation of Cisco Prime Collaboration Provisioning, Cisco Prime
Collaboration Assurance and Analytics Business, or Cisco Prime Collaboration Deployment .

Procedure

Step 1 In vSphere client, power on the VM that you deployed for the respective Prime Collaboration applications
(Cisco Prime Collaboration Provisioning, Cisco Prime Collaboration Assurance and Analytics Business, or
Cisco Prime Collaboration Deployment).

Step 2 Right-click the VM and choose Open Console.
A console window appears.

Step 3 At the login prompt, type setup.
Step 4 Follow the prompts to complete the installation.

Complete Cisco Expressway Installation
Use this procedure to complete installation of Cisco Expressway.

For detailed documentation on installing and setting up Cisco Expressway refer to http://www.cisco.com/
c/en/us/support/unified-communications/expressway-series/products-installation-guides-list.html.

Note

Procedure

Step 1 Power on and open the console of the virtual machine.
Step 2 At the login prompt, enter admin for username and TANDBERG for the password.
Step 3 At the Run Install Wizard prompt, type Y and press Enter.
Step 4 To change the password, type Y and press Enter.
Step 5 At the prompt, type the new password, and click Enter.
Step 6 In the next series of prompts, configure the following network details:.

• IP Protocol (Default is IPv4)

• IP address

• Subnet mask

• Default gateway IP address
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• Ethernet speed of the LAN (Default is auto)

Step 7 For the Run SSH (Secure shell) daemon, type Y and press Enter.
Step 8 At the Restart Now prompt, type Y and press Enter.
Step 9 After the system reboots, access the Cisco Expressway in a web browser.
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C H A P T E R  4
Post-installation

• Post-installation Task Flow, page 31

Post-installation Task Flow
Procedure

PurposeCommand or Action

Follow these steps to perform first-time setup and
apply licenses for your UC applications.

Set up Applications and Apply Licenses,
on page 31

Step 1

Optional. Install new locales for your UC
applications.

Install Locales or Patches for
Applications, on page 32

Step 2

After you have completed your installation, find
out where to go next.

Where to Go Next, on page 35Step 3

Set up Applications and Apply Licenses

This procedure applies to application licenses, not VMware licenses.Note

Follow these steps to access each application, perform first-time setup for some applications, and apply the
licenses.

Procedure

Step 1 To access the administration portal for each individual application, browse to the IP address of application.
Consider the following information:
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• Optional. For Paging Server installations: Collect information about the application URL from the virtual
machine console. The default first-time username and password are admin and changeMe.

• Cisco Prime Collaboration Provisioning: Browse to the IP address and use globaladmin as the username.

Step 2 After you purchase an application license, Cisco sends a Product Authorization Key (PAK) via mail or email.
You can use the PAK to generate a license key for your specific installation using the Cisco Product License
Registration portal at www.cisco.com/go/license or you can enter the information directly in Cisco Prime
License Manager.

Step 3 Apply license keys using the application administration portal. Refer to the following points for licensing
information specific to whichever applications that you have installed:

• Cisco Prime Collaboration Provisioning: No license is required to use Cisco Prime Collaboration
Provisioning Standard Edition. Youmay purchase an upgrade to Cisco Prime Collaboration Provisioning
Advanced Edition if required.

• Paging Server: No license is required to use Basic Paging Server. You may purchase an upgrade to
Advanced Edition if required.

• Unified Communications Manager, Cisco Unity Connection, and Cisco Emergency Responder: Browse
the IP Address of Unified Communications Manager and click Cisco Prime License Manager. Select
License > Install License File and follow instructions. Having installed your licenses, add application
instances for your UCM Publisher, Unity Connection and Emergency Responder VMs.

Cisco Prime License Manager (PLM) gets installed automatically as part of the Cisco Unified
Communications Manager and Cisco Unity Connection installation. Use only the instance that
is installed with the Unified CommunicationsManager publisher to manage all of your licenses.
Do not use separate Prime License Manager instances to manage Unified Communications
Manager and Unity Connection licenses separately. For details, see the Cisco Prime License
Manager User Guide at: http://www.cisco.com/c/en/us/support/cloud-systems-management/
prime-license-manager/products-user-guide-list.html.

Note

Related Topics

Product License Registration
Cisco Product Upgrade Tool (PUT)

Install Locales or Patches for Applications
Complete the following tasks to install locales or patches for your application VMs.

Note • Patches shippedwith the server were current at the time ofmanufacture. Visit http://software.cisco.com
for more recent updates.

• For additional information on locales, refer to the Phone Locale Installers wiki at: http://
docwiki.cisco.com/wiki/Cucm-phone-locale-installers.
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Procedure

PurposeCommand or Action

Associate the locale or patch installer with the
appropriate VM.

Associate Bundled Locale or Patch ISO
with VM, on page 33

Step 1

If you want to install locales or patches for Cisco
Unity Connection, stop the services before you
install the locale or patch.

Stop Services for Unity Connection, on
page 33

Step 2

Install the locale or patchon the VM.Install New Locales and Patches, on page
34

Step 3

Associate Bundled Locale or Patch ISO with VM
Use this procedure to associate your locale or patch images with the appropriate application VM before starting
the install process.

Procedure

Step 1 In vSphere client, select the VM on which you want to install a new locale or patch.
Step 2 Select Inventory > Virtual Machine > Edit Settings.
Step 3 From the Hardware tab, select CD/DVD Drive.
Step 4 Browse to the datastore OVA-ISO directory and select the appropriate locale or patch ISO file.
Step 5 Click OK.
Step 6 Under Device Status, enable the Connected option.
Step 7 Repeat this procedure for each VM for which you want to install a new locale or patch.

What to Do Next

If you want to install a locale or patch for Cisco Unity Connection, Stop Services for Unity Connection, on
page 33

Otherwise, proceed to Install New Locales and Patches, on page 34

Stop Services for Unity Connection
Use this procedure if you want to install a new locale or patch for Cisco Unity Connection. You must stop
services on the Unity Connection VM before you install a new locale or patch.
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Procedure

Step 1 Log in to Cisco Unity Connection Serviceability.
Step 2 Choose Tools > Service Management.
Step 3 Stop the following services:

• Connection Conversation Manager

• Connection Mixer

What to Do Next

Install New Locales and Patches, on page 34

Install New Locales and Patches
Use this procedure to install a new locale or patch for any UC applications on your Business Edition server.

Note • For Cisco Unified Communications Manager, you must install locales or patches for the publisher
node and restart it before you install it for any subscriber nodes.

• You can install locales for Cisco Unified Communications Manager and Cisco Unity Connection in
parallel.

Procedure

Step 1 Log in to Cisco Unified Communications OS Administration.
Step 2 Navigate to Software Upgrades > Install/Upgrade. The Software Installation/Upgrade window displays.
Step 3 From the Source drop-down list box, choose DVD/CD.
Step 4 Click Next.
Step 5 Select the update file that you want to install and click Next.
Step 6 After the download completes, click Next.
Step 7 After the locale or patch installs, restart the server:

a) Log in to vSphere Client.
b) Right-click the VM on which you installed the locale or patchand select Power > Restart Guest
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Where to Go Next
After you install your Cisco Business Edition 6000 server, you can provision users, devices and configure
features on the system. Refer to the following guides available at http://www.cisco.com/c/en/us/support/
unified-communications/business-edition-6000-version-11-5/model.html#~tab-component-documentation:

• Cisco Prime Collaboration Provisioning Guide for Cisco Business Edition 6000

• Cisco Prime Collaboration Assurance and Analytics Business Guide

• Cisco Prime Collaboration Deployment Administration Guide
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A P P E N D I X  A
Configure NIC Teaming for Business Edition 6000

• NIC Teaming, page 37

• Configure NIC Teaming, page 38

NIC Teaming
The Hypervisor NIC teaming feature allows multiple physical adapters to be associated with a vSwitch to
provide load sharing and failover connectivity to the external network.

Failover and Load Balancing

When additional physical adapters are assigned to a vSwitch, they may be assigned as either active or standby.
Depending on the way in which the server is connected to the physical network, traffic from virtual machines
may be load balanced across active connections and, in the event of a link failure, a standby adapter will be
made active to take over.

Switched Network Topologies

To maximize resiliency to failure, teamed interfaces are typically connected to different switching equipment.
This might involve connecting to separate line cards in a chassis, switches in a stack, or to completely
independent devices.

Where independent physical switches are used, teamed interfaces should be set to active, allowing the Ethernet
Spanning Tree protocol to block connections that create a loop. In the event of a link or switch failure, the
Spanning Tree protocol will reconverge to use a serviceable connection to the server. Where VLAN trunking
is used, the Spanning Tree protocol can typically be configured per VLAN to prefer different connections for
DMZ and internal network traffic under normal operation.

If connections are made to a common logical switch (i.e. chassis or cluster) that supports IEEE 802.3ad link
aggregation, it is possible to load balance traffic across all active members of the link group under normal
operation. Link aggregation can accommodate link failures more quickly than Spanning Tree and is transparent
to VLANs, so may be used with either dedicated network, or VLAN trunk connections.

The following table illustrates how Business Edition servers may accommodate network separation and NIC
teaming.
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Configure NIC Teaming
Procedure

PurposeCommand or Action

Configure NIC Teaming on a Cisco Catalyst
switch.

Configure NIC Teaming on Switch, on page
38

Step 1

Configure NIC Teaming for your Hypervisor
Virtualization ESXi.

Configure NIC Teaming in ESXi, on page
39

Step 2

Configure NIC Teaming on Switch
When aggregating server interfaces, the switch ports to which they are connected must be configured to use
802.3ad link aggregation. The following example illustrates how this may be configured using VLAN trunking
to a Cisco Catalyst switch:

vlan 1
name default
!
vlan 30
name DMZ
!
interface GigabitEthernet1/1
description BE Server Network Interface 1 (Internal/DMZ trunk group)
switchport trunk allowed vlan 1,30
switchport mode trunk
spanning-tree portfast trunk
channel-group 1 mode passive
!
interface GigabitEthernet1/5
description BE Server Network Interface 2 (Internal/DMZ trunk group)
switchport trunk allowed vlan 1,30
switchport mode trunk
spanning-tree portfast trunk
channel-group 1 mode passive
!

When connecting server interfaces to separate switches, use standard trunk port configuration (no
channel-group). Do not use Spanning-Tree Portfast.

vlan 1
name default
!
vlan 30
name DMZ
!
interface GigabitEthernet1/1
description BE Server Network Interface 1 (Internal/DMZ trunk)
switchport trunk allowed vlan 1,30
switchport mode trunk
!
The Spanning Tree VLAN cost command may be used balance traffic between links, if required.
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Configure NIC Teaming in ESXi

Procedure

Step 1 Log in to vSphere Client.
Step 2 in the left inventory panel, click the host icon.
Step 3 From the Configuration tab, select Networking.
Step 4 Click Properties to access the switch configuration.
Step 5 Select the Physical Adapters that should be added to the switch and click Next.

We recommend that you team amix of motherboard and PCI card network adapters.Note

Step 6 Use theMove Up andMove Down buttons to adjust the failover policy for the added ports. If you want to
use an adapter for failover, move the adapter from the Active Adapter list to the Standby Adapter list.

Step 7 Click Next.
Step 8 Click Finish.

If you don't need to configure IEEE 802.3ad link aggregation, you can close the vSwitch properties page and
skip the remaining steps.

Step 9 Configure IEEE 802.3 link aggregation:
a) From the vSwitch0 Properties page, Select the Ports tab and Edit the vSwitch object.
b) Select the NIC Teaming tab.
c) From the Load Balancing drop-down menu, select Route based on IP hash.
d) Click OK.
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