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Introduction

ERPLabel is a tool to cut down implementation time of bar code 
label printing in SAP™ R/3® ERP Systems. It will also eliminate 
the need for output management middle ware products in many 
cases.

The product will reduce implementation cost, as no middle ware 
is required. The implementation is also faster, since there is no 
need to learn programming with a printer command language. 
ERPLabel™ will provide output fi les that are used in SAPscript. 
These can be used without any manual editing, making the 
procedure quick and easy.

Maintenance cost is reduced as there is no middle ware or separate 
bar code printing system to maintain, as the printing will use the 
main R/3 system.
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Version 6 includes new features compared to version 5, including:

• Support for LabelShop PRO v6.11
• Support for EasyCoder C4, PF2i, PF4i, and PM4i printers
• Wizard for creating ITF fi les
• Support graphics and Stored mode from Direct Protocol driver
• Fingerprint driver no longer supported. You can now use Direct 

Protocol in Stored mode.
• Support for network installation

System
• LabelShop PRO v6.11 
• PC running Windows 98/Me/NT4.0/2000/XP
• Hardware requirements—standard for respective operating 

system
• Microsoft Internet Explorer 5.01 or later

Printers
EasyCoder 201 II, 301, 401, 501, 501 XP, 601, 601 XP, C4, E4, F2, 
F4, 3240, 3400, 3440, 3600, 4400, 4420, 4440, 4630, 4830, 7421, 
PF2i, PF4i, PM4i.

SAP R/3
SAP R/3 release 3.0A or later 

This manual contains the information necessary to install and use 
ERPLabel for SAP R/3, to set up printers, and upload ITF fi les to 
SAP R/3.

This manual was written for users who want to print labels from 
SAP R/3 on Intermec EasyCoder printers. These users must be 
familiar with using SAP R/3 and printing from SAP R/3.

Requirements

New in v6.0

Who Should Read 
This Manual
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If LabelShop is not installed already, you can install it from 
the ERPLabel CD. You can install ERPLabel locally or on the 
LabelShop PRO Net.

To install ERPLabel locally
1.  Put the ERPLabel CD in your CD drive.

 The CD should now automatically start and display the 
introduction screen.

Note: If the CD does not start automatically, start the 
Autorun.exe manually from the Start-Run prompt.

Installation
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2.  Click Install Software.

3.  If LabelShop is not already installed, select Install LabelShop 
PRO, and follow the instructions that appear.

Installation, cont.
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4. After LabelShop has been installed, select Install ERPLabel for 
SAP R/3.

5.  The proposed installation path appears. Click Yes to approve.

If you want to install it into another path, click No, and enter the 
desired path in the dialog box that appears.

To install ERPLabel on the LabelShop PRO Net
1.  From the LabelShop CD provided with the LabelShop PRO Net 

package, install LabelShop PRO Net on the server.

2.  At the Network installation type screen, choose Local 
installation.

3.  Finish installing LabelShop PRO Net on the server, and then 
install the clients from the server as described in the Installation 
Guide of LabelShop PRO Net.

4.  Install ERPLabel locally on each of the clients that should use 
ERPLabel for SAP R/3.

Installation, cont.
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ERPLabel can store label formats locally in the host system, “Host 
Mode,” or in the printer, “Stored Mode.”

Each method has advantages, which are described below.

Host Mode—Host Stored Label Format
•    The printer uses the host to send the complete label and data. 

The major advantage is that no application specifi c data is 
stored in the printer, so additional printers can be added or 
moved in the SAP R/3 system without having to prepare the 
printer.

•    True Type fonts can be used for fi xed texts and are sent as 
graphic data.

•    Fixed Graphics are sent to the printer at printout.

•    As Host Mode sends all data for every printout, the printout 
can be slower than Stored Mode, depending on the layout of the 
label. If graphics are included on the label, the throughput is 
lower than when using Stored Mode.

•    The throughput also depends on the speed of the communica-
tion interface between the host and the printer. Using large 
graphics with slow serial communication or slow Wide Area 
Network (WAN) links can give unacceptable performance. 
Stored Mode is preferable for such applications.

Working Modes
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Stored Mode—Printer Stored Label Format
•    Can store label formats in printer for optimized throughput. Ideal 

when using slow communication lines.

•    Graphics stored in printer.

•    True Type fonts can be stored in printer1 for use with fi xed or 
variable data.

•    Host sends variable data only, minimum overhead.

•    As Stored Mode only sends the variable data for the printout, the 
printout is faster than Host Mode.

•    If graphics are included on the label, some printers require Stored 
Mode as SAPscript cannot send the graphical data in the required 
format.

•    Stored Mode requires some more work and administration to keep 
it running, as each printer in the system needs to have the stored 
formats loaded prior to printing from the SAP R/3 system.

Working Modes,
cont.

1/. On selected printer models.
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The preferred working mode depends on the printer to be used, the 
application, and preferences.

To choose the working mode
1.  Decide which mode to use. The available options are shown in 

the Working Mode table.

2.  Locate the printer model to be used. 

3. Follow the instruction for the selected mode.

Hints
•    Host mode is recommended and works for most applications. 

Select this mode and print a test label. If the label prints well, 
continue using this mode.

• If you need to print a label with lots of graphics and are using slow 
communication lines, use Stored Mode.

Printer/ Language          Language        Host Mode     Stored Mode
EasyCoder 3240,
3400, 3440, 3600,                  IPL                   Yes                    Yes
4400, 4420, 4440,
4630, 4830, 7421,
PF2i, PF4i, PM4i

EasyCoder 201 II,
301, 401, 501,               Direct Protocol           Yes                   Yes
501 XP, 601, 601 XP,                                         
E4, F2, F4, PF2i, 
PF4i, PM4i

EasyCoder C4                     ESim                  Yes                    Yes
                                                              (if no graphics)

Choosing Working 
Mode
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LabelShop supports a full range of Intermec printers, while 
ERPLabel works with most of the printers.

To install your printer 
1. Select File > Select printer, or click the Select printer button. 

The Printer dialog box appears.

2. Click Add. The Add printer dialog box appears.

3. Expand the Intermec Default folder. ERPLabel only supports 
printers in the Intermec Default folder.

Installing Printers
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Installing Printers, 
cont.

4. From the Model frame, select your printer model, and from the 
Port frame, select the port the printer is connected to, and click 
OK.

5. Make sure the printer you added is selected, and click OK. 
LabelShop printers appear with a printer icon in front of the 
printer name. ERPLabel does not support printers that appear 
without the printer icon.

The name and port of the selected printer appear in the lower left 
corner of the LabelShop screen.
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You can open a pre-defi ned empty label that contains the correct 
printer settings. The following empty labels are included Program 
Files\Intermec\LabelShop PRO 6\Samples\Labels\SAP:

In the DP folder
Empty DP Stored Mode.lab
Empty DP Host Mode.lab

In the IPL folder
Empty IPL Stored Mode.lab
Empty IPL Host Mode.lab

In the C4 folder
Empty C4 Stored Mode.lab
Empty C4 Host Mode.lab

To get a correct output to SAPscript, the printer settings must be 
set up properly. You may get an unexpected result if the printer is 
not set up properly.

This section explains how to set Direct Protocol printers for Host 
mode and Stored mode.

To set up Direct Protocol printers for Host mode
1.  Install your printer. For help, see “Installing Printers” earlier in 

this guide.

2. Click the Printer setup button. The Printer settings dialog box 
appears.

Setting Up Direct 
Protocol Printers 

Finding the 
Sample Labels
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Setting Up Direct 
Protocol Printers, 
cont.

3.  In the General tab, set Send modifi ed data only to On.

4. Select the Images tab.
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5.  From the Image format for transfer to printer drop down list, 
select ASCII.

6. Select the Layout tab.

7. Set the following parameters:

Parameter Setting

Store layout in printer Cleared

Name images Cleared

Start of record 94 (̂ )

End of record 125 (})

Field separator 126 (~)

8. Click OK.

Your Direct Protocol printer is ready to print labels in Host mode.

To set up Direct Protocol printers for Stored mode
1.  Install your printer. For help, see “Installing Printers” earlier in 

this guide.

2. Click the Printer setup button. The Printer settings dialog box 
appears.

Setting Up Direct 
Protocol Printers, 
cont.
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3.  In the General tab, set Send modifi ed data only to On.

4.  Select the Images tab.

Setting Up Direct 
Protocol Printers, 
cont.
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5.  From the Image format for transfer to printer drop down list, 
select PCX.

6. Select the Layout tab.

7. Set the following parameters:

Parameter Setting

Store layout in printer Checked

Name images Cleared

Start of record 94 (̂ )

End of record 125 (})

Field separator 126 (~)

8.  Click OK.

Your Direct Protocol printer is ready to print labels in Stored 
mode.

Setting Up Direct 
Protocol Printers, 
cont.
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Setting Up IPL 
Printers

To get a correct output to SAPscript, the printer settings must be 
set up properly. You may get an unexpected result if the printer is 
not set up properly.

This section explains how to set IPL printers for Host mode and 
Stored mode.

To set up IPL printers for Host mode
1.  Install your printer. For help, see “Installing Printers” earlier in 

this guide.

2.  Click the Printer setup button. The Printer settings dialog box 
appears.

3. In the General tab, set the following parameters:

Parameter Setting

<STX><ETX> protocol Checked

Send modifi ed data only Checked

Reload images at next print job Cleared

Maximum number of images 0



ERPLabel for SAP R/3 v6.0 User's Guide  21

ERPLabel for SAP R/3

Setting Up IPL 
Printers, cont.

4. Select the Layouts tab.

5.  Clear the Store layout in printer check box.

6.  Click OK.

Your IPL printer is now ready to print in Host mode.

To set up IPL printers for Stored mode
1.  Install you printer. For help, see “Installing Printers” earlier in 

this guide.

2. Click the Printer setup button. The Printer settings dialog box 
appears.
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Setting Up IPL 
Printers, cont.

3. In the General tab, set the following parameters:

Parameter Setting

<STX><ETX> protocol Checked

Send modifi ed data only Checked

Reload images at next print job Cleared

Maximum number of images 0

4. Select the Layouts tab.
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5. Set the following parameters:

Parameter Setting

Store layout in printer Checked

With layout number* 2 to 19 or 2 to 99

Rebuild the whole label image Cleared

List the layouts stored in memory only Checked

    * The number of available layouts depends on the printer 
    model. EasyCoder 3240, 3440, 3400C, 4420, 4440, 7421, 
    PF2i, PF4i, and PM4i printers support 2 to 99 layouts. All 
    other IPL printers support 2 to 19 layouts.

6.  Click OK.

Your IPL printer is now ready to print in Host mode.

Setting Up IPL 
Printers, cont.
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Setting Up 
EasyCoder C4 
Printers

To get a correct output to SAPscript, the printer settings must be 
set up properly. You may get an unexpected result if the printer is 
not set up properly.

This section explains how to set EasyCoder C4 printers for Host 
mode and Stored mode.

To set up EasyCoder C4 printers for Host mode
1. Install your printer. For help, see “Installing Printers” earlier in 

this guide.
2. Click the Printer setup button. The Printer settings dialog box 

appears.

3.  In the General tab, check the Save settings in the layout check 
box.

4. Select the Layouts tab.
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Setting Up 
EasyCoder C4 
Printers, cont.

5.  Clear the Store layout in printer check box.

6.  Click OK.

Your ESim printer is ready to print in Host mode.

To set up EasyCoder C4 printers for Stored mode
1.  Install your printer. For help, see “Installing Printers” earlier in 

this guide.

2. Click the Printer setup button. The Printer settings dialog box 
appears.
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3.  In the General tab, check the Save settings in the layout check 
box.

4. Select the Layouts tab.

Setting Up 
EasyCoder C4 
Printers, cont.
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Label Design The label design for SAP is done just like any other label design, 
but there are a few things to keep in mind to make it work 
smoothly.

Fixed text: Can use printer resident or True Type fonts. 
As True Type fonts are transmitted as 
graphical bit maps, the printout is slower.

Variable text: Only printer resident fonts can be used.

Lines/Boxes: Supported.

Bar codes:  Fixed and variable supported. Use printer 
bar codes only.

Graphics: Use fi xed graphics only.

Polygons, circles,        Printed as graphics.
rounded rectangles:

Oblique lines: Printed as graphics (except EasyCoder C4).

OLE objects: Printed as graphics.

5.  Check the Store layout in printer check box.

6.  Click OK.

Your ESim printer is ready to print in Stored mode.

Setting Up 
EasyCoder C4 
Printers, cont.
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Defi ning Variable 
Data 

When using variable text fi elds in the label, you should use the 
variable fi eld names as used in SAP.

Variable (formula) names cannot contain curly brackets ({}) or 
ampersands (&).

If a variable used in the formula has a name containing one of the 
characters:  + - * / < > = ^ % , ! \ " , you must enclose the variable 
in curly brackets ({}).

If you want to use the underscore character in a name, enter a 
double underscore, such as SY__NAME for SY_NAME. The 
double underscore will be converted to a single underscore.

To defi ne variable data
1.  Click the Display Document Browser button.

2.  In the Data Sources tab, right click Form, and select Add. Var0 
appears under Form.

3.  Click Var0 to select it, click again or press F2, enter the name of 
the fi eld in SAP that the variable is for, and press Enter.

4.  Double click the variable. The variable dialog box appears.
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Defi ning Variable 
Data, cont. 

5.  In the Input tab, enter a sample value in the fi eld in the Variable 
value box so that the screen displays some typical data.

6.  Select the Output tab.
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7.  In the Maximum length fi eld, enter the maximum number of 
characters for the fi eld.

8.  Click OK.

1.  Click and drag the variable you want to add to the label to the 
label frame. A dialog box appears.

Defi ning Variable 
Data, cont. 

Using Variable 
Data in Label
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2.  Select whether you want the variable to display as text, bar 
code, or image. The variable data appears on the label. The 
following screen capture shows Part_No as a bar code.

3.  To move the variable data, click the Select Objects button, and 
then click and drag the variable data to where you want it.

4.  To change the parameters for the variable data, such as font 
type or bar code symbology, click the Select Objects button, 
and then double click the variable data.

Using Variable 
Data in Label, 
cont.
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Advanced Use of 
Variables

It is possible to design concatenated fi elds using formulas. 
Concatenated Fields are useful when you want to:

•    merge two or more R/3 fi elds.

•    combine R/3 fi elds with fi xed data.

•    combine R/3 fi elds with non-printable characters.

Formulas can include control characters, EOT (ASCII 4), GS 
(ASCII 29), and RS (ASCII 30).  Including control characters is 
useful when printing bar codes with embedded control characters, 
for example in EDI messages in two dimensional (2D) bar code 
symbologies.

When building formulas for UCC/EAN 128 bar codes, FNC1 
(Function Code 1) is needed. You use the control character (FNC1) 
in for such cases. For more information, see “Example 2: EAN128 
With Two Merged Data Fields” later in this guide.

Note: Printer fonts normally do not print control characters.

Note: When using control characters in the labels in 
combination with Direct Protocol and EasyCoder C4 printers, 
you must change the code page in SAP to Code Page 9163 for 
LB_UBI/ZLB_UBI (Direct Protocol) and Code Page 9999 for 
ZLB_C4. For help loading code pages, see “Uploading a Code 
Page” later in this guide. 
LB_INT and ZLB_INT device types support control characters 
(including FNC1) by default.

To design a concatenated fi eld
1.  Declare the individual fi elds, even if they are not used 

separately.

2.  Create the concatenated fi eld using a formula.

The following examples explain how to create specifi c 
concatenated fi elds.

Special Characters Syntax
Character ASCII Value (dec)

{EOT} 4

{GS} 29

{RS} 30
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Advanced Use of 
Variables, cont.

Example 1: Code 128 With Manufacturer's Part Number
Example 1 explains how to create the following label including a 
Code 128 bar code with the manufacturer's part number, using a 
FACT Data Identifi er (DI). The DI for part number is 1P.

This label, “Code 128 XX Host Mode.lab” (XX=IPL, DP, or C4), 
can be found in the Samples\SAP directory.

To create the Example 1 label
1.  Defi ne a variable named Part_No with a length of 20. For help, 

see “Defi ning Variable Data” earlier in this guide.

2.  Defi ne a variable named Description with a length of 25. For 
help, see “Defi ning Variable Data” earlier in this guide.

3.  In the Data Sources tab, right click Formula, and select Add. 
Formula0 appears.

4.  Select Formula0, then click Formula0 or press F2 to make the 
name editable, and enter Formula BC_PN.

5.  Right click Formula BC_PN, and select Variable properties. 
The Formula BC_PN dialog box appears.
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Advanced Use of 
Variables, cont.

6.  Type "1P"&.

7.  Select Variables, select Part_No, and click Insert.

8.  Select the Output tab.
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  9. In the Maximum length fi eld, enter 22.

10.   Click OK.

11.   In the Data Sources tab, right click Formula (1), and select 
Add. Formula1 appears.

12.   Select Formula1, then click Formula1 or press F2 to make the 
name editable, and enter Formula HR_PN.

13.   Right click Formula HR_PN, and select Variable properties. 
The Formula HR_PN dialog box appears.

14.   Type "(1P) "&. (There is a space after the close parenthesis.)

15.   Select Variables, select Part_No, and click Insert.

16.   Select the Output tab, and set the length to 24.

17.   Drag the formulas and variables to the label, and select Text 
or Barcode as appropriate.

Example 2: EAN128 With Two Merged Data Fields
Example 2 explains how to create a label including an EAN128 
bar code with two merged data fi elds.

Advanced Use of 
Variables, cont.

This label, “EAN128 Var Length XX Host Mode.lab” (XX=IPL, 
DP, or EasyCoder C4), can be found in the Samples\SAP 
directory.
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The bar code should include two internal data fi elds:

AI for Location is 90 (Internal Use only)

AI for Product Group is 91 (Internal Use only)

As the length of the fi elds are not fi xed, you need to put a separator 
character (that is, an FNC1) between the Location Field and the AI 
for the product group, that is {FNC1}&90&Location&{FNC1}&91
&Product_Group.

To create the Example 2 label
1.  Defi ne a variable named Location with a length of 10. For help, 

see “Defi ning Variable Data” earlier in this guide.

2.  Defi ne a variable named Product_Group with a length of 10. 
For help, see “Defi ning Variable Data” earlier in this guide.

3.  Defi ne a variable named Product_Name with a length of 25. 
For help, see “Defi ning Variable Data” earlier in this guide.

4.  In the Data Sources tab, right click Formula, and select Add. 
Formula0 appears.

5. Select Formula0, press F2 or click again, and enter Formula 
BC_LOC_PG.

6. Right click Formula BC_LOC_PG, and select Variable 
properties. The Formula BC_LOC_PG dialog box appears.

Advanced Use of 
Variables, cont.
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  7.   Type "{FNC1}"& "90"&.

  8.   Select Variables, select Location, and click Insert.

  9.   Type & "{FNC1}"&"91"&.

10.   Select Variables, select Product_Group, and click Insert.

11.   Select the Output tab.

12.   In the Maximum length fi eld, enter 26.

13.   Click OK.

14.   In the Data Sources tab, right click Formula, and select Add. 
Formula1 appears.

15.   Select Formula1, then click Formula1 or press F2 to make the 
name editable, and enter Formula HR_LOC_PG.

16.   Right click Formula HR_LOC_PG, and select Variable 
properties. The Formula HR_LOC_PG dialog box appears.

17.   Type "(90) "&.

18.   Select Variables, select Location, and click Insert.

19.   Type & "(91) "&.

20.   Select Variables, select Product_Group, and click Insert.

21.   Select the Output tab, and set the length to 28.

22.   Click OK.

23.   Drag the formulas and variables to the label, and select Text 
or Barcode as appropriate.

Advanced Use of 
Variables, cont.
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Test Print–Host 
Mode

When the label has been completed, it is time for a test print prior 
to getting the label into the SAP R/3 system.

Print the label by clicking the Print button or selecting File > 
Print.

When you are satisfi ed with the result, make sure the fi le is saved. 

If the printer driver was set to Stored mode, an additional dialog 
box appears. For more information, see the next section.

If you are going to use Stored mode, you have to store the current 
label layout in the printer.

You store the layout while printing the current label to the 
connected printer. It works slightly differently depending on the 
printer attached.

Using Direct Protocol
When you print the label, you are prompted for a layout name. 
Existing stored labels are shown.

Storing Label in 
Printer
(Stored Mode Only)

Enter a suitable name in the Layout name fi eld. Make a note of the  
name as you need to enter it when the script is saved for SAPscript.

Note: If you use a name of a current layout, that layout will be 
overwritten.
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Using IPL
The layout will refer to the number selected in the driver settings 
(in the Forms tab).

Note: If the printer contains a layout on the current store position, 
it will be overwritten.

Using EasyCoder C4
When you print a label, you are prompted for a layout name. Enter 
the desired name of the label. You can use a maximum of eight 
characters for the layout name. Ignore the KDU country code.

Storing Label in 
Printer, cont.
(Stored Mode Only)

If the layout contains graphics, you are prompted for 
the name of each graphic. Enter a name up to eight 
characters long. Each graphic must have a unique name, 
no matter what layout it is in.
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The SAP R/3 system requires a specifi c output format (ITF fi le) to 
be used. You can create the ITF fi le using the ERPLabel Wizard or 
using LabelShop.

Using ERPLabel Wizard
1.  Create your label, and save it to disk. For help, see the 

LabelShop documentation.

2.  Set up your printer. For help, see one of the sections for set-
ting up printers earlier in this guide. The target printer must be 
installed before you run the Wizard.

3.  From the Start menu, select Programs > Intermec ERPLabel 
for SAP > ERPLabel Wizard. The ERPLabel Wizard screen 
appears.

    From LabelShop, select Tools > ERPLabel Wizard.

Making Output
File for SAPscript

4.  Click Next, and follow the instructions that appear in each 
screen.

    If you choose Stored mode for a Direct Protocol or EasyCoder 
C4 printer, you are prompted for the layout name that you set in 
“Storing Label in Printer” earlier in this guide.

5.  When the ITF fi le has been successfully created, the following 
screen appears.

    If there is an error, follow the hint that appears on the screen, or 
see “Error Messages” later in this guide to correct the error.
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Making Output
File for SAPscript, 
cont.

6.  To open the ITF fi le in a text editor, such as Notepad, click 
Open destination folder.

7.  In the Finished dialog box, click Back to step back and create a 
different ITF fi le, or click Exit.

Using LabelShop
This section explains how to create ITF fi les in LabelShop for Host 
mode and Stored mode.

Host Mode
1.  Create your label, and save it to disk. For help, see the 

LabelShop documentation.

2.  Set up your printer for Host mode. For help, see one of the 
sections on setting up printers earlier in this guide.

3.  Select File > Export > as a printer object fi le (POF) > 
Template SAP HostMode.poc. The Save As dialog box 
appears.
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Making Output
File for SAPscript, 
cont.

4.  Save the fi le with your desired name on a location where 
the SAPscript can reach it. By default, the Print directory of 
LabelShop is proposed, but it can be changed at will.

LabelShop creates an ITF fi le with the same name, but with the 
extension ITF. The original fi le is deleted. For example, if you 
created the output fi le sap _ addr.pof, LabelShop generates 
the fi le sap _ addr.itf.
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Stored Mode
1.  Create your label, and save it to disk. For help, see the 

LabelShop documentation.

2.  Set up your printer for Stored mode. For help, see one of the 
sections on setting up printers earlier in this guide.

3.  Select File > Export > as a printer object fi le (POF) > 
Template SAP StoredMode.poc. The Save As dialog box 
appears.

Making Output
File for SAPscript, 
cont.

4.  Save the fi le with your desired name on a location where 
the SAPscript can reach it. The default directory is the Print 
directory of LabelShop.

    If you are using a Direct Protocol or EasyCoder C4 printer, you 
are prompted for the layout name after you click Save. For help, 
see “Using Direct Protocol” or “Using EasyCoder C4” earlier 
in this guide.

LabelShop creates an ITF fi le with the same name, but with the 
extension ITF. The original fi le is deleted. For example, if you 
created the output fi le sap _ addr.pof, LabelShop generates the 
fi le sap _ addr.itf.
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Using Direct Protocol
When prompted for a layout name, enter the desired name.

Enter the same name as entered when the layout was stored when 
printing. If a different name is given, SAPscript will not print the 
label correctly.

Making Output
File for SAPscript, 
cont.

Using IPL
The layout refers to the number selected in the driver settings (in 
the Forms tab).

Using an EasyCoder C4 Printer
When prompted for a layout name, enter the desired name.

Enter the same name as entered when the layout was stored when 
printing. If you enter a different name, SAPscript will not print the 
label correctly.

If the layout contains graphics, you are prompted for a name for 
each graphic. The name of the graphic must be identical to those 
entered when the layout was stored when printing. If you enter a 
different name, SAPscript will not print the label correctly.
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Making Output
File for SAPscript, 
cont.

Checking the 
Printer 
Connection

Prior to printing from SAP R/3, the printer connection should 
be checked outside of R/3. This will confi rm that the printer is 
properly connected to the operating system, prior to creating the 
output devices in R/3.
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Uploading ITF File 
to SAP

You use transaction SO10 to copy the contents of the ITF fi le into 
a clipboard area in SAP, which can then be pasted into the SAP 
Form. 

Note: This manual uses SAP R/3 v4.6c to describe handling 
of ITF fi les, code pages, and Device Types. Some steps may be 
slightly different in other versions of SAP R/3, but experienced 
SAP users should be able to use this guide to help them accomplish 
the steps.

To upload ITF fi le
1.  Log in to SAP.

2.  Go to transaction /NSO10.

3.  In the Text name fi eld, enter a name, and then click Create.
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4.  Select Goto > Change Editor.

5.  Select Text > Upload.

6.  Select the ITF radio button, and press Enter.

7.  At the end of the ITF fi le fi eld, click the Drop down button, 
browse to your ITF fi le, and open it.

Uploading ITF File 
to SAP, cont.
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  8. Place your cursor on the fi rst row on the fi rst column of the 
paragraph format (not text), and press F2.

  9. Scroll to the end of the text, place the cursor on the last line 
on the fi rst column of the paragraph format fi eld, and press 
F2. All of the text is now highlighted.

10.  Select Edit > Selected area > Copy to user clipbrd > 
Clipboard 1.

11. Click Exit.

12. When prompted to cancel text, click Yes.

Uploading ITF File 
to SAP, cont.
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Creating a 
New SAP Form 
(SAPscript)

1.  In SAP R/3, go to transaction /NSE71.

2.  In the Form fi eld, enter a name for your new SAP form 
(SAPscript), and click Create. A message box appears.

3.  Click the Check button.
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4.  In the Description fi eld, enter a description for the form.

5.  Click Pages.
Creating a 
New SAP Form 
(SAPscript), cont.

6.  In the Page fi eld, type FIRST, and press Enter.

7.  In the Description fi eld,  type First Page.

8.  Click Paragraph formats.
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  9. In the Paragraph fi eld, type X, and press Enter.

10. In the Descript. fi eld, enter a description, and then press F5.

11. Click Basic Settings.

Creating a 
New SAP Form 
(SAPscript), cont.

12. In the Default paragr. fi eld, type X.

13. In the First page fi eld, type FIRST.

14. Click Page windows, and select Edit > Create Element.
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15. Double-click the entry for MAIN.Creating a 
New SAP Form 
(SAPscript), cont.

16. In the Window width fi eld, type 210.00 MM, and in the 
Window height fi eld, type 291.00 MM.

17. Press F9, and select Goto > Change Editor.
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18. Select Insert > Clipboard > User Clipboard > 
Clipboard 1.Creating a 

New SAP Form 
(SAPscript), cont.

19. Press F3.
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20. Press Ctrl + S.Creating a 
New SAP Form 
(SAPscript), cont.

21. Assign a development class and transport as needed, or click 
Local Object if this is only a test form.

22. Select Form > Activate.

23. Create a new ABAP print program, or modify an existing 
one, as necessary.
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Uploading a Code 
Page

You need to use a non-standard code page in the following 
situations:

•    For the EasyCoder C4 printer, you need Code Page 9999.

•    For printing the Euro character ( € ) and special non-printable 
characters on Direct Protocol printers, you need Code Page 
9163.

•    For printing the Euro ( € ) character on IPL printers, you need 
Code Page 9998.

To upload a Code Page
1.  In SAP R/3, go to transaction SPAD.

2.  Select Utilities > For Character Sets > Import.
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  3. In the Character set number fi eld, enter 9163 for Direct 
Protocol, 9998 for IPL, or 9999 for EasyCoder C4.

  4. Check the File system: GUI check box.

  5. Select the Upload (fi le -> R/3) radio button.

  6. Check the Update/delete when uploading check box.

  7. Click the Execute button.

  8. Click Yes.

Uploading a Code 
Page, cont.
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  9. Assign a development class and transport as necessary.

10. Click Save.

11. Click the Drop down button for the File name fi eld.

12. Browse to the character set fi le, S9999.cpa, S9998.cpa, or 
S9163.cpa, select it, and then click Open. On the CD, the fi les 
are under \Codepages\.

13. Verify the fi le path, and then click Transfer.

Uploading a Code 
Page, cont.
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14. Review the upload report for errors.

Uploading a Code 
Page, cont.
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Setting Up an 
Output Device 
(Printer)

1.  Log in to SAP.

2.  Go to transaction /NSPAD, and select the Devices/Services tab.

3.  Clear the Output devices fi eld, and then click the Output 
devices button.

4.  Press F8, and then press Shift + F1.
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5.  In the Output device fi eld, enter a descriptive name for the 
printer, and in the Short name fi eld, enter a short name for the 
printer.

6.  From the Device type drop down list, select the type of printer 
you have: LB_INT (IPL) or LB_UBI (Direct Protocol). 

    Older versions of SAP R/3 need ZLB_INT (SAP note 183777) 
or ZLB_UBI (SAP note 137069). 

    If you have an EasyCoder C4 printer, load the device type 
ZLB_C4 from the ERPLabel CD.  For help, see the next 
section, “Importing a Device Type.”

7.  In the Spool server fi eld, select the location that houses the 
print queue.

8.  Click the HostSpoolAccMethod tab.

Setting Up an 
Output Device 
(Printer), cont.
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  9. In the Host spool access method drop down list, select L: 
Print locally using LP/LPR, and in the Host printer fi eld, 
enter the queue name.

10. Save settings.

Setting Up an 
Output Device 
(Printer), cont.
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Importing a 
Device Type

1.  Upload the required code page. For help, see “Uploading a 
Code Page” earlier in this guide.

2.  In SAP, go to transaction SPAD.

3.  Select Utilities > For Device Types > Import.



ERPLabel for SAP R/3 v6.0 User's Guide  63

ERPLabel for SAP R/3

Importing a 
Device Type, cont.

4.  Select the Device Type radio button.

5.  In the Object name fi eld, enter ZLB_C4 for the EasyCoder 
C4 printer, ZLB_INT for IPL printers, or ZLB_UBI for Direct 
Protocol printers.

6.  Click the Execute button or press F8.
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7.  Assign a development class and transport as necessary.

Importing a 
Device Type, cont.
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8.  At the end of the File name fi eld, click the Drop down button, 
and browse to the ZLB_C4.PRI, ZLB_INT.PRI, or ZLB_
UBI.PRI fi le. 

9.  Click Transfer. The following screen appears confi rming that 
the device type has been imported.

Importing a 
Device Type, cont.
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Optimizing the 
Throughput

If you fi nd the throughput is not satisfactory, use the hints below to 
optimize the speed.

Choosing the Font
Choose between printer resident fonts, bitmapped fonts, and 
scaleable fonts.

To change the font
•    Double click the text in the label. The Text dialog box appears.

Printer Resident Fonts
You should also use printer resident fonts for fi xed text. If you use 
Windows fonts, these fonts are sent as graphics causing the label to 
print slower.

You can scale printer resident fonts in various ways. There are two 
types of fonts: bitmapped or scaleable (sometimes referred to as 
outline fonts).

Note: You must use printer resident fonts for variable text.
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Optimizing the 
Throughput, cont.

Scaleable Fonts
You can scale these fonts into any size. Width can be entered in 
percent of the nominal width, which makes it very fl exible. 

Select the point size (or mm or inch) and then the width and height 
in percent, if the nominal size doesn’t meet your needs.

Example: 

First set the height to 16 points, then decrease the width to 67%.

If Windows fonts are required and speed is essential, use Stored 
mode as an alternative.

Graphics
Minimize the amount of graphics and the size of the graphics if 
possible. Consider to use Stored Mode if this is practical.

Copies
If printing multiple identical labels, the speed can be increased 
by using the Multiple Copies function. For help, see one of the 
sections on setting up printers earlier in this guide.

Bitmapped fonts
Bitmapped fonts are fi xed size fonts that you can expand (multiply) 
either horizontally or vertically. This expandability enables you 
to get a narrow font by expanding the height by 2 and keeping the 
width at 50%.

Example: 
First set the point size to 5, then the height to 2, and then decrease 
the width to 50%.
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If you have defi ned an Intermec EasyCoder printer in your R/3 
system, for example “P1,” in runtime SAPscript merges the 
defi ned ITF fi le with the data from your R/3 database and send it 
to the spooler as an OTF fi le.

The printing is made using a specifi c device type used for the 
“upload method,” which is the technique utilized by ERPLabel.

The generated spool fi le is handled by the Generic Text Driver of 
the Operating System.

How does the 
printing work in 
SAP R/3?

Printer P1

Print on P1
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As ERPLabel uses /& as a placeholder for the variables, do not use 
this string in a label. If used, an Error Message appears (Error 513 
– Odd number of fi eld delimiters).

The Direct Protocol uses some printable characters in the communi-
cation protocol. These are user defi nable, but are preset to:
Start of record  ^  (ASCII 94 dec.)
End of record  } (ASCII 125 dec.)
Field separator  ~ (ASCII 126 dec.)

Selecting Direct Protocol - Override Protocol overrides the 
protocol delimiters set in the LabelShop driver. If you need to 
use delimiters for data, you can use up to three start and stop 
characters, e.g. ### and $$$, which enables you to use a single or 
double character as data. The record separator can only be a single 
character. This feature is not supported for EasyCoder 301 and E4 
printers.

The printer driver must be set up properly to obtain the expected 
results that SAPscripts expect. There is a separate section for each 
printer command language and mode. Follow these instructions 
carefully.

General 
Limitations

Printer Setup
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There is a fi ne tuning tool included in the ERPLabel. The purpose 
is to set some parameters that can improve the performance or 
assist in Debugging in case an error should occur.

To access ERPLabel setup
•    In LabelShop, select Tools > ERPLabel Setup. The ERPLabel 

Setup dialog box appears.

Using ERPLabel 
Setup

General tab
Use the General tab to set the following parameters.

Output File Line Length
Sets the maximum length of the ITF fi le lines. Default is 74. 
SAPscript can not accept more than 74.

Post Process > Remove Input File
Default On. Set it to Off, If you want to keep the initial POF fi le 
even after converting it to a ITF fi le, for debugging purpose.

Post Process > Show Input File
Default Off. Set it to On, if you want to bring up the Input File 
in your favorite editor during the test phase. You will have to 
associate the extension for the POF fi le with your Editor, to make 
it work.

Post Process > Show Output File
Default Off. Set it to On, if you want to bring up the ITF File 
in your favorite editor during the test phase. You will have to 
associate the ITF extension with your Editor, to make it work.
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Multiple Copies
By default, SAP R/3 will send down the complete label data for every 
printed label. It is possible to maximize the printer throughput when 
printing multiple copies of a label. If the “Multiple copies” box is 
enabled, it is possible to specify a fi eld name that contains the SAP 
variable for print quantity. Default name is ZERP-QTY, but it can 
be changed to any desired name.

Note: The SAP application must enable the user to specify the 
number of copies variable at print time.

Printer tab

Using ERPLabel 
Setup, cont.

Use the Printer tab to set the following parameters.

Remove Setup
The ITF fi le normally contains setup strings to set the printer to 
the number of parameters, for example desired print mode, select 
media type, print contrast, direct thermal or thermal transfer 
printing.

If the printer uses the same media type and size at all times, this 
information may not be necessary to send with every label. For 
these cases, you can confi gure the printer to use that media and 
check the Remove Setup check box.
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Using ERPLabel 
Setup, cont.

Direct Protocol - Override Protocol
The Direct Protocol uses some printable characters in the 
communications protocol. These are user defi nable, but are preset 
to:

Start string ^ ASCII 94 dec.

End string } ASCII 125 dec.

Separator character ~ ASCII 126 dec.

A string of characters sent to the printer with this setting looks like 
this:

1̂1-900000-92~ERPLabel~Add on for LabelShop PRO~}

To enable correct printing, the variable data must not contain any 
of the delimiter characters.

In applications where there is no possibility to reserve three 
printable characters, the Override protocol will override the 
standard protocol and enable you to defi ne a reserved one to three 
character string for Start string and End string. The Separator 
character will maintain a single character. 

Note: EasyCoder 301 and EasyCoder E4 do not support Override 
protocol, as they can only use one delimiter.

Start string
Select the desired two or three characters from the drop down list.

End string
Select the desired two or three characters from the drop down list.

Separator character
Select the desired single separator character from the drop down 
list.
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If you are designing several labels it may be useful to pre-defi ne 
the variables. Instead of having to defi ne the fi elds every time, you 
can re-use the fi eld names over and over.

To reuse fi eld names, create an ASCII table with comma-delimited 
records.

Sample database
Part_No,Product_Name,Description,Location,Product_Group

”11-900000-92”,”ERPLabel”,”Add on for LabelShop PRO”,”656A1”,”SW”

”11-300200-02”,”LabelShop PRO”,”Label Design Software”,”887B2”,”SW”

”11-400300-02”,”LabelShop ULTRA”,”Label Design Software”,”888B2”,”SW”

ERPLabel includes such a table, Products.txt. It can be found 
in the Data directory. 

To make a table of SAPscript variables
1.  Create a text fi le with the fi elds and some sample records as 

previously shown, and place this fi le in the Data directory.

2.  Create a describer fi le. (Consult the LabelShop manual or the 
On-line help for details).

3.  To use the database in the design mode, in LabelShop select 
Merge > Open ASCII database or press F9.

Making a Table
of SAPscript
Variables

4.  In the Data fi le box, click the button to open the text fi le you 
created.

5.  In the Describer box, click the button to open the describer you 
created.

6.  Click OK.
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Making a Table
of SAPscript
Variables, cont.

The variables are now available in the Database section of the 
Document Browser.
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Error Messages Error 513. Odd number of fi eld delimiters
ERPLabel uses the string “/&” to identify the variables. This error 
may show if you have used “/&” in a text string in the label. Change 
the string to use some other data, for example “/

SPACE
&” or substitute 

the “&” character with the word “and.”

Error 514. Driver not set to Stored Mode
You have tried to generate a fi le for Stored Mode, but the driver is 
set to Host Mode.

Change the driver to use Stored Mode in Printer-Settings-Layout.

Change the driver to use Stored Mode in Printer-Settings-Layout, 
that is, check the box “Store layout when printing.”

Error 515. Input fi le X:\Path\Filename.POF contains non-printable 
characters
SAPscript does not permit non-printable characters.

You have probably used a graphic text or bar code object for a 
driver that does not permit such data. 

Check that you have not, for example, ....
• defi ned a graphical bar code—change to a printer bar code
• defi ned a graphical text for a DP driver.

Error 516. POF fi le corrupt or empty
The POF fi le has been corrupted or damaged. Please check that a 
correct fi le has been generated. Make a new try. If problem occurs 
again, please contact your supplier.

Error 518. Driver not set to <STX><ETX> protocol
You have tried to generate an ITF fi le from an IPL driver. The 
printer driver is not correctly confi gured, as it will generate 
non-printable characters. Go to Printer > Settings > General. 
Activate the tick box <STX><ETX> protocol, and try again.

Error 519. Driver not set to Host Mode
You have tried to use Host Mode output, but the driver is set to 
Stored Mode.

Change the driver to use Host Mode in Printer-Settings-Layout, 
that is, uncheck the box “Store layout when printing.”
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Error 520. No input fi le *.POF could be found
The POF was never created. Please retry. If problem continues, check 
your LabelShop and ERPLabel installation.

Error 521. Formula: xxxxxxxxxxx Function not allowed. 
Formula contains non-supported expression.
You have used expressions in the formula that ERPLabel does 
not support. This may, for example, be a check digit calculation 
or a logical expression. ERPLabel supports only concatenation of 
constants, variables, and special characters.

Error 522. Formula: xxxxxxxxxxx Char Function not supported.
You have tried to use an ASCII character using the char(nnn) 
statement. Use the printable syntax, for example {RS} for ASCII 
30.

Error 523. Formula: xxxxxxxxxxx Nested formula not supported.
You cannot use a formula inside another formula. Make the vari-
able as a formula in one step.

Error 524, File ERPSYS.INI contains invalid settings.
Settings have been corrupted. Re-install the software.

Error 525, Data separator should be a printable character
The DP driver must be set to use a printable character. Go to the 
layout tab of the printer settings and select three printable characters 
as data separators. Detailed information can be found in “Setting Up 
Direct Protocol Printers” earlier in this guide.

Error 526, The driver has to be set to 'Send modifi ed data only'
In order to provide correct output, the driver must be set to ‘Send 
modifi ed data only’. Click Printer setup and go to the General tab. 
Detailed information can be found in one of the sections for setting 
up printers earlier in this guide.

Error 527, Formula: xxxxxxxxxxx. Formula name or variable name 
cannot contain '&' character
As SAP R/3 uses & to tag variables, the ampersand (&) character 
cannot be used in formula names or variable names. Change the 
formula or variable name to remove the ampersand.

Error Messages, 
cont.
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Error 528, Formula contains string without quotes
Strings in a formula must be written within quotes, for example, 
“1111”&VAR-1&“2222”&VAR-2.

Error 529, Fingerprint mode not supported. Use DP mode driver 
instead
Fingerprint drivers cannot be used in ERPLabel 6. Install the DP 
mode driver for this printer instead. Press F5 to add a printer, and 
select it from the Printer group Intermec default.

Error 530, Code page conversion table is corrupted or could not be 
found
Check if the fi le “cmap.txt” is present in the ERPLabel directory. If 
it is missing, reinstall ERPLabel.
   

Error Messages, 
cont.



ERPLabel for SAP R/3 v6.0 User's Guide78

ERPLabel for SAP R/3



ERPLabel for SAP R/3 v6.0 User's Guide  79

ERPLabel for SAP R/3



ERPLabel for SAP R/3 v6.0 User's Guide80

ERPLabel for SAP R/3

ERPLabel™ for SAP™ R/3® v6.0 User's Guide

*1-960609-00*
P/N 1-960609-00

Intermec Printer AB
Idrottsvägen 10, P.O. Box 123
S-431 22 Mölndal, Sweden

tel +46 31 869500

fax +46 31 869595

www.intermec.com


	Contents
	Introduction
	New in v6.0
	Requirements
	System
	Printers
	SAP R/3

	Who Should Read This Manual
	Installation
	Working Modes
	Host Mode—Host Stored Label Format
	Stored Mode—Printer Stored Label Format

	Choosing Working Mode
	Installing Printers
	Finding the Sample Labels
	Setting Up Direct Protocol Printers
	Setting Up IPL Printers
	Setting Up EasyCoder C4 Printers
	Label Design
	Defining Variable Data
	Using Variable Data in Label
	Advanced Use of Variables
	Example 1: Code 128 With Manufacturer's Part Number
	Example 2: EAN128 With Two Merged Data Fields

	Test Print–Host Mode
	Storing Label in Printer (Stored Mode Only)
	Using Direct Protocol
	Using IPL
	Using EasyCoder C4

	Making Output File for SAPscript
	Using ERPLabel Wizard
	Using LabelShop
	Host Mode
	Stored Mode


	Checking the Printer Connection
	Uploading ITF File to SAP
	Creating a New SAP Form (SAPscript)
	Uploading a Code Page
	Setting Up an Output Device (Printer)
	Importing a Device Type
	Optimizing the Throughput
	Choosing the Font
	Graphics
	Copies

	How does the printing work in SAP R/3?
	General Limitations
	Printer Setup
	Using ERPLabel Setup
	General tab
	Printer tab

	Making a Table of SAPscript Variables
	Error Messages

